We are experiencing issues with our email provider causing delays in email sending

Incident Report for Sequel

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 21:01 UTC

Monitoring

Our vendor has implemented a fix and we are monitoring the performance.
Posted Sep 10, 2025 - 20:55 UTC

Identified

We identified an issue with our email provider SendGrid that is causing emails to be delayed. We are actively working with the vendor to solve the issue.
Posted Sep 10, 2025 - 20:22 UTC
This incident affected: Emails.